For trainers to work properly, the following components are required.
Important components are marked in red * you need to install both for x86 and x64 no matter what bit depth your operating system is!

Drivers NvidiaAMD     (Lack of drivers may cause the lack of Aero Glass mode (Window Transparency))
Download
Visual C++ 2005
Visual C++ 2008 
Visual C++ 2010  x86 / x64
Visual C++ 2012  x86 / x64
* Visual C++ 2013  x86 / x64 
* Visual C++ 2015  x86 / x64
* Visual C++ 2017 x86 / x64
DirectX 9.0c | DirectX 11
Net.Framework 4
Net.Framework 4.5
Net.Framework 4.5.1
Net.Framework 4.5.2
Net.Framework 4.6
An excellent solution that includes all VC ++ libraries from 2005 to 2017 (it does not put outdated garbage and fix bugs)
Hybrid x64
Hybrid x32
ATTENTION
After installing the components, restart the PC!